2006 PT Cruiser coolant hose

by Wayne
(Escondido, Calif. USA)

2006 PT Cruiser

2006 PT Cruiser

My 2006 PT Cruiser over heated the other day. My mechanic said the lower coolant hose rubbed against the radiator assembly causing the hose to weaken and then burst. The technician said he thinks it was put together wrong. As a result the motor lost its coolant and overheated and lost oil. He says motor is burnt out. My question is - Is there or has there been any other reports of this problem?

In some car forum I saw a Cruiser owner complaining about an engine problem but with a different cause. He also got the PT used at 11k miles; after about a week and a half his fan fuse was going out almost as fast as he could replace it. So it overheated many times till the service department at the Chrysler dealership replaced the wiring harness to the radiator fan motor.

It was still overheating so after wasting 2 weeks time on diagnostics and different mechanics trying different things all involved decided it would be best and or easier to just replace the engine under warranty. I'm wondering why dealerships are willing to cover some items that would cause engine failure like a blown fuse to the coolant fan motor but would not cover an engine failure when the root cause is a hose that failed due to improper installation from the factory.

If you search around the Internet you can find lots of people having engine failures on all different years of the PT cruiser. In some cases problems are covered and in other cases no assistance is given at all by either the dealership or Chrysler. I have seen a few with the same exact situation but with different results. Its hard to tell when a customer has not turned off the engine fast enough to prevent damage or if they showed carelessness and just kept driving a vehicle overheating.

Comments for 2006 PT Cruiser coolant hose

Average Rating starstarstarstarstar

Click here to add your own comments

Apr 02, 2012
Rating
starstarstarstarstar
Is my Cruiser motor blown?
by: Anonymous

Me and a friend were riding down the interstate, and we began to smell something coming from under the hood. It smelled like the car was overheating, but the gauge on the dash was showing that it was normal. Well, I kept driving, going 70, and the car began to slow down on its own, till it just cut off and the steering wheel locked up.

At this point, there is a ton of smoke coming from under the hood. After we pop the hood and call a tow truck, a little over an hour has passed, so the car has cooled down. I try to start it, and it turns over, but it doesn't start. So, does that mean that the engine isn't blown? If so, then what do you think it is?

Jun 16, 2010
Rating
starstarstarstarstar
2006 PT cruiser radiator hose
by: Mark

Wayne: I checked the official technical service bulletins from Chrysler for your specific year and model. I could not find any releases related to the coolant hoses or cooling system.

I personally have not heard of any issues about improper installation of the lower radiator hose causing overheating. But we can see if anyone finds your post and leaves a comment about having the same problem.


Click here to add your own comments

Join in and write your own page! It's easy to do. How? Simply click here to return to Car Repair Story.